KYC Airtel Money Gabon incident

Incident Report for Digitech Status Production

Resolved

Pertubation de connectivité chez airtel money
Posted Nov 06, 2025 - 07:11 UTC

Investigating

Our monitoring system has detected an incident with airtelmoney on KYC. Investigation is in progress. We will keep you posted
Posted Nov 04, 2025 - 14:17 UTC
This incident affected: Plateforme E-Billing (KYC Airtel Money Gabon).