KYC Airtel Money Gabon incident

Incident Report for Digitech Status Production

Resolved

Souci technique interne
Posted Apr 07, 2026 - 12:48 UTC

Investigating

Our monitoring system has detected an incident with airtelmoney on KYC. Investigation is in progress. We will keep you posted
Posted Apr 07, 2026 - 11:56 UTC
This incident affected: Plateforme E-Billing (KYC Airtel Money Gabon).